Dateidatum wird nicht übertragen (WebDAV)

Deutscher Support für die Software AllSync
Post Reply
Panurg
Posts: 14
Joined: 16 Jun 2009, 15:26

Dateidatum wird nicht übertragen (WebDAV)

Post by Panurg »

Hallo Experten,
ich habe ein WebDAV-Verzeichnis für MS OneDrive erstellt. Dort hinein habe ich jetzt testweise einen Ordner kopiert, mit einigen Dateien. Dann habe ich eine Datei lokal gelöscht. Ein erster AllSync-Lauf (1:1 Kopie) funktioniert, die Datei ist jetzt auch remote weg.
Aber: Alle Dateien remote haben das Datum des letzten AllSync-Laufs, nicht mehr ihr originales Datum wie lokal. Folge: Auch wenn gar nichts geändert wurde, werden die remote Dateien immr als unterschiedlichesDatum erkannt - - und folglich abermals von lokal nach remote kopiert.
Ich habe nun die Option "Dateidatum nach dem Kopieren übertragen" gefunden - und gesetzt. Leider ohne den erhofften Erfolg.
Was mache ich verkehrt? Oder wird das bei dieser WebDAV-Ordnergeschichte nie so gehen?

P
Administrator
Site Admin
Posts: 3673
Joined: 04 Oct 2004, 18:38
Location: Thailand
Contact:

Re: Dateidatum wird nicht übertragen (WebDAV)

Post by Administrator »

Dies ist ein bekanntes Problem von OneDrive welches schon seit Jahren von Microsoft immer noch nicht behoben wurde: es wird immer automatisch der aktuelle Zeitpunkt als Zeitstempel für kopierte Dateien gesetzt!
m Prinzip ist OneDrive damit unbrauchbar für eine Datensynchronisation.
Fragen Sie mal bei diversen Konkurrenzprodukten nach ob diese ein solch selbstverständliches Feature unterstützen.
Panurg
Posts: 14
Joined: 16 Jun 2009, 15:26

Re: Dateidatum wird nicht übertragen (WebDAV)

Post by Panurg »

Hallo nochmal,
Danke für die Antwort.
Ich dachte nun, dass in AllSync in Dateioptionen -> Optionen -> Dateidatum nach dem Kopieren übertragen
genau für diesen Fall vorgesehen ist.
Wenn aber nicht, - was ist dann damit gemeint?

P
Administrator
Site Admin
Posts: 3673
Joined: 04 Oct 2004, 18:38
Location: Thailand
Contact:

Re: Dateidatum wird nicht übertragen (WebDAV)

Post by Administrator »

Damit wird auch der Befehl zum Übertragen des Dateidatum ausgeführt, aber wenn der OneDrive-Server diesen Befehl ignoriert...
LostSoul
Posts: 14
Joined: 17 Oct 2016, 12:26
Location: Gotha, Thüringen
Contact:

Re: Dateidatum wird nicht übertragen (WebDAV)

Post by LostSoul »

Hallöle,

ich würde mich hier gerne nochmal ran hängen.

Ich habe ein ähnliches Problem mit der FritzBOX. Habe eine SMB2 Freigabe erstellt und möchte nun jeweils ein lokales Verzeichnis auf die NAS der Box synchronisieren. Das Dateidatum der Dateien ist verschieden und wird auch wie schon vom TO angemerkt anscheinend nach dem kopieren nicht korrekt übertragen. Das bedeutet das wenn ich keine Dateien ändere er jedes mal an die 25GB auf die Box kopieren will. Dieses Problem tritt nur mit AllSync auf!

Wie muss ich die FB konfigurieren damit das Problem nicht mehr auftritt? Die FritzBox ist eine 7490 mit FRITZ!OS: 07.26 (weitere HW, wenn nötig in der Sig)

Greetz
LostSoul
Geboren in einer stürmischen & verschneiten Nacht im April des Jahres 1972 und bis heute nicht Erwachsen geworden…
Image
Wer ohne Sünde ist, werfe den ersten CD Player! --- Wenn ich ein Pferd wäre, hätte man mich schon längst erschossen!!!
Administrator
Site Admin
Posts: 3673
Joined: 04 Oct 2004, 18:38
Location: Thailand
Contact:

Re: Dateidatum wird nicht übertragen (WebDAV)

Post by Administrator »

Wie groß ist der Unterschied bei dem Änderungsdatum von Quell- und Zieldatei nach einem Kopiervorgang?

Eventuell können Sie mit der Kopierregel "Dateien mit einem unterschiedlichen Änderungsdatum von bis zu..." das Problem lösen.
LostSoul
Posts: 14
Joined: 17 Oct 2016, 12:26
Location: Gotha, Thüringen
Contact:

Re: Dateidatum wird nicht übertragen (WebDAV)

Post by LostSoul »

Das ist eine gute Idee. Die Option ist mir auch schon ins Auge gefallen. Ging davon aus das Sie zur Korrektur von Zeitzonen Fehlern gedacht ist. Doch wenn der Versatz kontinuierlich gleich ist... Ich sehe mir das an. Danke für den Tipp.

UPDATE I - 20210514: Ich hatte leider noch keine Zeit das zu testen...

UPDATE II - 20210611: Also die Fritz!Box 7490 (FRITZ!OS: 07.27) lässt es nicht zu das die Dateizeiten geändert werden. Nach einer Kopie erscheint die Aufstellungen der Zeiten wie folgt.

Änderungsdatum: Zeit der Kopie
Erstellungsdatum: Zeit der vorherigen Kopie [*]
Zugriffsdatum: Zeit der vorherigen Kopie [*]
[*] Erscheint erst wenn man nach dem Kopiervorgang erneut eine Vorschau startet.

Dieses Verhalten sieht man bei "Abarbeiten" und auch bei "Kopieren".

Ich werde demnächst mal auf einen RASPI synchronisieren. Wäre natürlich unvorteilhaft wenn AllSync oder Raspberry Pi OS dort dasselbe Verhalten zeigen.

UPDATE III - 20210611:
Ich stelle gerade fest das das unter NTFS auch nicht immer funktioniert obwohl ich eher glaube das da einen Konfigurationsfehler habe.

ORDNER LINKS 19.01.2021 - ORDNER RECHTS 11.06.2021 (HEUTE)

Kopiert wurde von links nach Rechts. Den Ordner gab es rechts nicht. Nun sagt das Programm es wäre alles synchron. Für die Anzahl der Dateien und Ordner stimmt die Aussage. Für die Ordner Daten (ist doch die Mehrzahl von Datum?) stimmt das so aber nicht. Die Datei Daten hat er beim erstellen übernommen.

Ich habe mal versucht das ganze zu colorieren, das liest sich dann besser.

Wenn ein Ordner schon vorhanden ist, wie kann ich dann sein Datum anpassen wenn es sich in der Quelle geändert hat?

Greetz
LostSoul
Geboren in einer stürmischen & verschneiten Nacht im April des Jahres 1972 und bis heute nicht Erwachsen geworden…
Image
Wer ohne Sünde ist, werfe den ersten CD Player! --- Wenn ich ein Pferd wäre, hätte man mich schon längst erschossen!!!
Post Reply