don't trim field "Ignore specific characters from..."

English support for the software AllDup
Post Reply
botmtl
Posts: 2
Joined: 10 Dec 2016, 07:24

don't trim field "Ignore specific characters from..."

Post by botmtl » 17 Jun 2018, 05:47

Image

There is a trim of this field before it is saved to options. The problem is that a "space" (chr(20)) is something a user may want to ignore. Workaround for users is to put the space anywhere except at the first or last position.

User avatar
Administrator
Site Admin
Posts: 3531
Joined: 04 Oct 2004, 18:38
Location: Thailand
Contact:

Re: don't trim field "Ignore specific characters from..."

Post by Administrator » 20 Jun 2018, 11:29

We dont use any trim-function to remove leading or trailing spaces at this option BUT after some investigations we found out that the windows api function we using for writing/reading ini-files does it automatically. it looks like some devs at microsoft thought it would be a nice-to-have feature and there is no option to deactivate it...
Anyway, we have fixed the problem. Thx for the feedback!

Post Reply